Support Article
SMTP Connectivity Test fails for email account
SA-10445
Summary
When users test the connection for an email account, the connectivity with the exchange server fails.
SMTP Connectivity Test > Test Connectivity to Email Account Default shows a Status of FailedConfiguration and the error message.
Error Messages
A secure connection could not be established with the outgoing(SMTP) email server. Check the application server configuration.
Steps to Reproduce
Test the connection from the email account.
Root Cause
The email account is trying to establish a secured connection from a non-secured port.
Resolution
To resolve the issue, choose one of the following approaches:
Alternative 1: Provide a secured SMTP port and check the option Use SSL to establish a secured connection.
Alternative 2: Disable TLS and try to establish connectivity using the original setting (Port 25 without SSL).
To disable TLS, specify the following Dynamic System Setting (DSS):
Purpose: Email/DisableSecuritySTARTTLS
Owning Ruleset: Pega-IntSvcs
Value: true
To add the DSS, perform the following steps:
- Go to Records > SysAdmin > Dynamic System Setting to open the DSS page.
- On the DSS page, click the Create button.
- Specify the field values shown in the following image and click the Create and Open button.
Short description: STARTTLS setting
Owning Ruleset: Pega-IntSvcs
Setting Purpose: Email/DisableSecuritySTARTTLS - Specify the Value field as “true” and click Save.
- To test the DSS, go to the DSS main page, enter START in the Search field, and click Run.
- Confirm that you have the DSS values shown in the image below. These are the field values that you specified in Steps 3 and 4.
- After adding the DSS, restart the JVM (Application Server).
Published September 26, 2018 - Updated October 8, 2020
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