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Support Article

SOAP Resource Unavailable Exception

SA-1666

Summary



There is a 2-minute delay logging in to PRPC due to the "ResourceUnavailableException: SOAP service failed"

Error Messages



Error in the log:
2014-09-19 19:02:27,202 [ WebContainer : 5] [ STANDARD] [ ] [application :.00.00] ( internal.mgmt.Executable) ERROR server user - Exception
com.pega.pegarules.pub.services.ResourceUnavailableException: SOAP service failed
at com.pegarules.generated.activity.ra_action_invokeaxis2_277a614fbe91c48716a315468a219545.step8_circum0(ra_action_invokeaxis2_277a614fbe91c48716a315468a219545.java:1481)

...
Caused by: 
com.pega.apache.commons.httpclient.ConnectionPoolTimeoutException: Timeout waiting for connection


Steps to Reproduce



Log in to PRPC

Root Cause



The InvokeAxis2 activity was customized and saved to customer ruleset before upgrading to Pega 7.1.6. This out-of-the-box rule was subsequently patched in Pega 7.1.6 and was ignored after the upgrade. In the latest InvokeAxis2, the maxHostConnections is 100 and the maxTotalConnections is 1000. Without these explicit settings, the default is 2 and 10 respectively. We would get the ConnectitonPoolTimeoutException.



Resolution



Use the out-of-the-box InvokeAxis2.

Published January 31, 2016 - Updated October 8, 2020

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