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Support Article

SOAP service failed

SA-5204

Summary



In a flow design where an SLA agent will trigger the work object to proceed to the next shape and make a SOAP connection, the SOAP connection failed. The error seen was a "PKIX path building failed" with SunCertPathBuilderException saying "unable to find valid certification path to requested target". If an operator manually open the work object and proceed it, the SOAP connection was successful.

Error Messages



The following error message was shown in tracer log.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target


Steps to Reproduce



Create a flow where it has an assignment with an SLA, followed by a utility shape to make a SOAP connection.
In the SLA's escalation activity, make a call to ResumeFlow activity.

Root Cause



The root cause of this problem is a defect in customer application code/rules. There were multiple factors found during the troubleshooting:
  • The access group used by the SLA agent in the lower environment where the scenario worked was not migrated to production environment where the scenario failed.
  • Upon calling ResumeFlow activity, the parameter "call from SLA" was found as false when it is suppose to be true.
  • It was also observed that if the SOAP call was done when the work object is opened by an operator (e.g. in review mode), the SLA escalation activity will fail saying it couldn't get a lock of the work object.
  • There were also other causes related to the environment configuration and application specific custom code that had to be addressed.

Resolution



This issue is resolved through the following local change:
  • Apply the correct access group to the agent that has access to all the rules required to make the SOAP connection
  • Set the parameter "Call from SLA" to true when calling ResumeFlow in the SLA escalation activity
  • Make sure the work object is not opened at the time the SLA agent is trying to proceed the flow
  • Make sure the SOAP service is up and any other 3rd party integration points have no issue

Published January 31, 2016 - Updated October 8, 2020

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