Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Some LDAP users cannot login to the Pega application

SA-20363

Summary



When a user login into the Pega application, while some set of users are able to login. This application uses Active Directory for authentication.

"Authentication failed: User not found in directory"


Error Messages



"Authentication failed: User not found in directory"


Steps to Reproduce



1. login to the pega application & notice the error on the screen.


Root Cause



A defect or configuration issue in the operating environment. Problematic user belongs to different group in Active Directory, hence the error message 'User not found in directory'.

Resolution



Here’s the explanation for the reported behavior: 

Since these two group of users in directory are under different node in directory, created second LDAP authentication service in Pega to authenticate second set of users and given different URL so they can be authenticated accordingly & access the application.

 

Suggest Edit

Published February 27, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us