Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Spacing issue in template preview

SA-17004

Summary



Unnecessary spaces are inserted into a word in Preview of Free form Email in SI.


Error Messages



Not Applicable


Steps to Reproduce



1. Try to create a correspondence. 
2. Select role as 'Inquirer' and language as 'English' and click on submit. 
3. Select 'Struct-Email/Struct-Fax/Struct-Letter' as correspondence type. 
4. Select correspondence as 'Free form Email'. 
5. Click on Next and Next again. 
6. Edit the header/body/closing segments and provide some data after some line breaks. 
7. Click on preview and observe that some spaces are inserted between the words/messages.


Root Cause



The 'Word Wrap' in AssembleHeader/AssembleBody/AssembleClosing/AssembleBodyTickler1/AssembleBodyTickler2 rules is creating the problem and inserting spaces in between a word. Below is the screen shot.




The word wrap is used for SWIT messages and not for Struct Email/Letter/Fax. So removed the word wrap in all the rule segments.

Resolution



The HFIX-24916 resolves the reported behavior.

 

Suggest Edit

Published January 31, 2016 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us