Support Article
Special characters change to ASCII automatically
SA-32208
Summary
Pega changes special characters to ASCII values.
Error Messages
Not applicable
Steps to Reproduce
1) Start a workflow of FTE Approval.2) Give any Name in Subject field which contains special characters and length is of > 64 ( for now to reproduce the error).
3) Go to the last step and click Submit workflow.
4) Error message appears on screen.
Root Cause
The issue is due to customized configuration.
Resolution
Perform the following local-change:
Compare the strings on the both sides and remove extra call to encode in next step while assigning to property encoding with crossScript API.
Published March 2, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.