Support Article
SSO timeout activity does not get triggered automatically
SA-30553
Summary
SSO Timeout activity configured in Authentication Service instance is not getting triggered after timeout period.
Error Messages
Not applicable
Steps to Reproduce
1. Update the AutheticationService with Timeout activity.
2. Specify the Timeout in Access Group.
3. Wait for the Timeout perod, observe that the Timeout Activity is not triggered automatically.
Root Cause
"pySAMLWebSSOTimeoutActivity" activity is not automatically getting called after the timeout.
However, it is being called after the timeout by the action made to Pega.
Resolution
"pySAMLWebSSOTimeoutActivity" gets called upon action made to the timed out Pega instance, so it is expected behavior in the product.
Published December 8, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.