Support Article
Subcases are locked when parent case is locked
SA-1774
Summary
A user is not able to resolve subcases if the cover case is locked. According to PDN the updates required for the cover should be queued.
https://pdn.pega.com/case-management/about-pega-7-case-locking
To over-ride default locking user followed below steps:
- Open the subcase type in the Case Designer's Details tab.
- Open the Locking pop-up dialog.
- Select the "Do not lock the parent case when the child case is being performed" checkbox and click the Save button.
However if we assign work status as “Resolved-Completed” for the subcase it will try to update parent case and end up throwing an error:
** Could not lock the cover E-XX ; Administrator has it. Please wait and try again later. Where E-XX is the parent case and Administrator operator has lock on it.
Root Cause
Submitted product enhancement request item as an Engineering Subject Matter Expert (SME) confirmed that the feature described below and documented on PDN is not implemented yet.
“If the parent is locked (by another subcase), the updates in the overridden case are queued until the system can obtain a lock for it”
Resolution
This issue is scheduled to be resolved in a future release.
PDN article https://pdn.pega.com/case-management/about-pega-7-case-locking was misleading and has been corrected accordingly to reflect the current behaviour.
Published January 31, 2016 - Updated October 8, 2020
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