Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Sync error after new code deployment and access group change

SA-104647

Summary



Post deploying the code and changing access groups for operators, mobile synchronization fails.


Error Messages



Mobile app data-sync failed with error code 4 (CLIENT_DB_FAILURE) and message "error code 19: UNIQUE constraint failed: offline_storage.type, offline_storage.handle, offline_storage.softflag"


Steps to Reproduce

  1. Have an existing application.
  2. Release a new code to the application.
  3. Change the Operator's access group.
  4. Log in to the mobile application.


Root Cause



A software use or operation error.
Code deployments were made and access groups were changed without full synchronization.



Resolution



For code or rule changes, initiate a full synchronization to reflect the changes.
To change the access group for a mobile operator, the operators must clear their application data or must reinstall the application.

Published June 2, 2020 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us