Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

"System" cannot be a valid party

SA-25466

Summary



After having migrated from PRPC 5 to Pega 7.1.9, the WorkObject creation using SLA agent is not working. 
It was working fine in PRPC 5 and apparently not working anymore on Pega 7.1.9.


Error Messages



Not Applicable.


Steps to Reproduce



1) Send a task to an Agent. The agent creates a new case.
3) Add the originator as a party into the case.
4) Observe that the case will not be created.



Root Cause



This behaviour is due to the new validation within activity Data-Admin-Operator.WorkPartyRetrieve in Pega-ProcessEngine : 07-10-19.

Within the first step there is a check if the created WorkParty is having the value “System” as Data-Party.pyWorkPartyUri:


 

Resolution



The behavior reported here is the expected one.
Create an OperatorID called "System" is not allowed and having a party added to the case as "System" is not the best practice.
The code is less permissive now and this is why the case does not get created.

 

Published July 26, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice