Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

System Page : Application not setup for REST Service

SA-32213

Summary



Developer reported that when accessing the system via a REST service, the System Page: Application does not seem to be initialized.

Error Messages



Not applicable

Steps to Reproduce



1. Create a REST service that call an activity.
2. In that activity get info like name and version of the application from system page: Application (Rule-Application).
3. Press the service by enabling tracer. The information cannot be found in the tracer as well as clipboard.


Root Cause



An issue in the custom application code or rules. This is expected behavior. 

Resolution



Here’s the explanation for the reported behavior: 

The requestor created for listeners and services is of type APP,  the system pages such as pxRequestorApplication, an so on, are kept lightweight and may not contain all the data that one would normally see when user logins to Pega through a browser.

 
Suggest Edit

Published January 18, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us