Support Article
Tab is not getting created after switch portal
SA-33572
Summary
When the user switches from one portal to interaction portal.
Tab is not getting created on new phone call or opening an interaction from the worklist, it is replacing the Home tab.
Error Messages
Not Applicable
Steps to Reproduce
1) Login to Application.
2) Launch a portal.
3) Switch to Interaction Portal.
4) Now create a new phone call or open interaction from worklist.
Root Cause
A defect in Pegasystems’ code or rules
When tryig to open the interaction after the switch portal pyRecentListItems are not getting updated.
On further analysis it is observed that on switch portal D_CPMPortalContent.PortalName is not updated.In pyDefault Data Transform of CPM-Portal class when condition D_CPMPortalContext.PortalName=="" is failing at Step 1.1.
It is checking whether PortalName is empty or not but in the issue scenario, it already contains the value of the previous portal.
Resolution
Perform the following local-change:
When condition in 1.1 is updated to pyAlwaysTrue:

Published February 20, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.