Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Task appears twice in interaction driver navigation panel

SA-25938

Summary



Duplicate tasks appear on left navigation panel. 

Error Messages



Not Applicable.


Steps to Reproduce



1. Login with credentials as cscsysadmin/install.
2. Create a sample case (a task in Customer Service for communications portal).
3. Launch "Interaction Portal". 
4. Create a New case, New->Demo Screen Pops->Demo Pop - ABC(or any user). 
5. Click "Add Task" on left navigation panel. 
6. Observe that a pop up window appears, select the task created in step 2.
7. Scroll down and click on "Add Task(s)".
8. Click on "Done" on warning page, if appears.
9. Observe that the selected task is appearing twice in the left navigation panel, every time it is added. 


Root Cause



"D_CPMServiceCaseRecents" data page is responsible for loading recent items in the left navigation panel. When a new task is added and a new harness is created, an entry is made in the "D_CPMServiceCaseRecents" data page.

Again, when perform harness is called for the same task a duplicate entry is made in the data page. Thus resulting in display of duplicate task in navigation panel.

Resolution



User must select "Skip create harness" option, under Flow>Process(Tab)>Skip create harness(Checkbox).

Once this option is checked, every time new harness will not be created, thus duplicate entries are avoided in "
D_CPMServiceCaseRecents" data page.

Published August 3, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us