Support Article
Testing and debugging email listeners
SA-16697
Summary
The documentation for Pega 7.1.x describes the steps required for debugging the emailListener:
https://pdn.pega.com/sites/default/files/help_v717/procomhelpmain.htm#data-/data-admin-/data-admin-connect-/data-admin-connect-emaillistener/testing.htm?Highlight=EmailListener
After Step 3 ( Start the System Management application. Select the node and select Logging and Tracing.), there is no place to execute Step 4 (Select the listener. Click Start at the top of the panel. Enter a requestor ID and password)
How should email listeners be debugged?
Error Messages
Not applicable.
Steps to Reproduce
Not applicable.
Root Cause
A portion of the information on that help document is out of date.
Resolution
Enabling debug on the following class should provide additional output for connectivity issues:
com.pega.pegarules.integration.engine.internal.services.email.EmailListener
Additionally, in the Service email rule (Go into the listener, then open the rule listed under Service Method), under the action drop down click on “trace”. This will open a tracer window that will populate with data once the listener processes an email.
Published January 31, 2016 - Updated October 8, 2020
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