Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

TextEncrypted property value is not getting decrypted on UI

SA-43956

Summary



After implementing a site specific cipher, encrypted properties are displayed in their encrypted value, even when ShowTextEncryptedPropertyValue in the property General tab is set.


Error Messages



Not Applicable


Steps to Reproduce



1. Install site specfic cipher
2. Create property of type text encrypted with the ShowTextEncryptedPropertyValue control and corresponding When rule.
3. Add property to UI and run flow. See that even though when rule access is satisfied the property value is being displayed in as encrypted instead of decrypted.


Root Cause



An issue in the custom application code or rules

When the property was added to the section the control was set at Text Input. It needs to be "Control inherited from property" to use the ShowTextEncryptedPropertyValue from the property rule or explicitly set to use that control.

Resolution



Perform the following local-change:

In the section click on the gear to the right of the property to open up the cell properties and change to select Inherit from Property under the Advanced list.

Suggest Edit

Published December 18, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us