Support Article
UI becomes unresponsive on resizing CPMInteractionPortal windows
SA-73660
Summary
The User Interface (UI) becomes unresponsive on resizing the CPMInteractionPortal windows on the Internet Explorer 11 browser. The sections are not resized and the scroll bars do not display.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Interaction portal on the Internet Explorer 11 browser
- Log in as the CASysAdmin
- Create an inbound interaction
- Select or create a contact
- Open the composite screen
- Resize the screen
Root Cause
The issue was with the Flex which was not supported on the Internet Explorer 11 browser.
Resolution
Perform the following local-change:
- Change the format of the Perform Harness(PegaCA-Work-Interaction-Call) to ‘No Markup’
- Set the Layout mode of DLs on the CPMInteractionPortalHeader section to Legacy
- Update the Layout mode DLs on the CSInteractionHeaderTemplate (design template)
- Add a style to non-flex on the CTIEndUser-Delta Cascading Style Sheets (CSS) for the removed flex styling on the CSInteractionHeaderTemplate section
Add the below code to the UserWorkForm to tackle the text overlap issue with the header:
div[node_name="CPMInteractionHeader"] .content-stacked_with_labels_left>.content-item>.content-inner {
display: block;
height: 100%; }
Published March 26, 2019 - Updated December 2, 2021
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