Support Article
Unable to accept Chat Request in SAML Authentication
SA-105707
Summary
Pega Chat 8.2.1 is running on Pega Customer Service (CS) 8.1 and Pega Platform 8.1.7.
When an agent accepts a Chat request in the Integration Portal, an error message displays on a blue screen. This occurs when the agent accesses the system through SAML or Single Sign-On (SSO).
Error Messages
There has been an issue; please consult your system administrator
Status: fail
Operator:
Node: No ID available

java.lang.NullPointerException: null
at com.pega.pegarules.session.internal.mgmt.authentication.engine.AuthenticationPolicyEngine.getPoliciesList(AuthenticationPolicyEngine.java:80) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.authentication.engine.AuthenticationPolicyEngine.getPolicy(AuthenticationPolicyEngine.java:91) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.authentication.engine.AuthenticationPolicyEngine.execute(AuthenticationPolicyEngine.java:116) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.authentication.SchemePRAuth.performPostAuthentication(SchemePRAuth.java:1529) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.mgmt.authentication.Authentication.performPostAuthentication(Authentication.java:2746) ~[prprivate.jar:?]
at com.pega.pegarules.session.internal.engineinterface.service.HttpAPI.handleAuthentication(HttpAPI.java:2580) ~[prprivate.jar:?]
at com.pega.pegarules.session.external.engineinterface.service.EngineAPI.activityExecutionProlog(EngineAPI.java:594) ~[prenginext.jar:?]
at com.pega.pegarules.session.external.engineinterface.service.EngineAPI.processRequestInner(EngineAPI.java:433) ~[prenginext.jar:?]
Steps to Reproduce
- Log in to the application through SSO.
- Connect to the Chat server and queues.
- Accept an incoming chat request.
Root Cause
For all messaging interactions (such as, Chat, Email, or Facebook), Pega uses the Associate Requester thread apart from the main Interaction thread for the Live Chat or Email area. The reason for this implementation is to make the interaction faster. Since the Live Chat area is loaded in the Associate Requester thread's Context, exchanging chat messages is faster with frequent refreshes which does not slow down the overall interaction.
This issue with Associate Requester with SSO, that caused the reported issue.
Resolution
This feature is implemented in Pega Platform 8.2.
Published April 4, 2020 - Updated December 2, 2021
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