Support Article
Unable to access Elastic HTTP Backend
SA-92553
Summary
Unable to access the REST APIs associated with an embedded instance of Elastic Search HTTP Backend which is pre-packaged with the Pega application.
Error Messages
ERR_EMPTY_RESPONSE
Steps to Reproduce
- Add the below settings to prconfig.xml:
<env name="indexing/distributed/http/enabled" value="true" />
<env name="indexing/distributed/http/port" value="9200" />According to the Setting requirements, the below setting is disabled on the Search Settings page,
Encrypt search inter-node communications
- Set the settings and access the Elastic Search HTTP Endpoint at http://{host}:9200.
Root Cause
Conflict on Port 9200. The port was used by another application on the host environment.
Resolution
Perform the following local-change:
Ensure that the port selected for this setting is open on the network and is not used by any other application.
<env name="indexing/distributed/http/port" value="PORT_NUMBER" />
Published February 10, 2020 - Updated December 2, 2021
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