Support Article
Unable to access the SMA of the remote JBOSS node
SA-9537
Summary
We have two JBoss instances installed in a machine. When accessing SMA of second JBoss instance from the first one using Remote connection - SMA standalone, an error occurs.
Error Messages
No MBeans found for the node <<node name>>
Steps to Reproduce
1. Configure the SMA of multiple instance in a common place.
2. Do this by adding nodes in the SMA.
Root Cause
RMI access was not configured in JBoss.
Resolution
Add following configurations in the run.conf file of the destination JBoss to allow RMI access:
Dcom.sun.management.jmxremote.port=<<RMI Port>>
Dcom.sun.management.jmxremote.authenticate=false
Dcom.sun.management.jmxremote.ssl=false
DJBoss.platform.mbeanserver
Djavax.management.builder.initial=org.JBoss.system.server.jmx.MBeanServerBuilderImpl
Published May 13, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.