Support Article
Unable to attach files on iPad
SA-56104
Summary
User is unable to attach files on iPad. Only files available to choose on iPad to attach are image file types (png/jpg).
All other file types show image in grey and they can not be selected. Other file types can be attached using desktop or Android mobile.
Error Messages
Not Applicable
Steps to Reproduce
1. Open Safari on iPad.
2. Login to application.
3. Create a case, try to attach a file other than an image to the case.
Root Cause
This is a known limitation when working with Safari and iPad devices. The standard file upload processing only allows user to add files from photo library.
Resolution
Enable option in the application to allow Safari access. Once Safari is enabled the File Upload will allow user to select files from the other applications.
As an alternative other applications like iCloud, DropBox, Google Drive or OnDrive can be used.
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.