Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to capture and attach screenshots to a case

SA-48077

Summary



Unable to capture and attach screenshots to a case using the Pega out-of-the-box Screenshot Capture functionality.


Error Messages



Cannot capture screen. Target window position not found


Steps to Reproduce

  1. Configure the SECTION/HTML rule AttachmentHTML or ActionAttachaScreenshot
  2. Select Attach Screenshot from the dropdown (all the open windows are available for the screenshot).
  3. Select the PBS application from the dropdown list and click the Attach Screenshot button.


Root Cause



An issue in the custom application code

When a desktop window is shared between all open documents for an application (for example, Microsoft Excel), the screen capture tool does not select the exact document from all the open documents. The PBS application works similarly.
Hence, this is not an issue with the screen capture tool but with the PBS application where window management is different.


Resolution



Perform the following local-change:

Activate the respective document and proceed with the screenshot.



Published March 26, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice