Support Article
Unable to create top level case with pxCreateTopCase
SA-18974
Summary
An agent was set up within the ruleset of the application. This was configured according to the documentation in advanced mode. The agent will not be fed in queue items. It is set to run pxCreateTopCase in the context of the class. The class name was passed to the activity as well. The agent fails when it is run. An error occurs in catalina.out.
Error Messages
**Date and time**,464 [ PegaRULES-Batch-1] [ STANDARD] [ ] [ PegaRULES:07.10] ( hasMessages._baseclass.When) ERROR - Exception caught while evaluating when
java.lang.NullPointerException
Steps to Reproduce
1. Create agent within application ruleset.
2. Add an advanced agent, which calls the pxCreateTopCase activity in the context of the top case's class.
3. Pass that class to the ClassName parameter of pxCreateTopCase.
4. Run the agent.
Root Cause
An issue in the custom application code or rules. hasMessages When rule failed because stepPage was missing. hasMessage is called at the end of Step 2 of pxCreateTopCase. hasMessages is basic validation check that is done on stepPage. Primary page was not set when pxCreateTopCase was called through an agent.
Resolution
1. Use another activity, which has extra step for Page-New.
2. Call pxCreateTopCase.
Published April 12, 2016 - Updated October 8, 2020
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