Support Article
Unable to create work object via agent, calendar exception
SA-7550
Summary
An Agent has been created in order to create WorkObjects using case management feature. The Activity used within the Agent configuration is running as expected outside the Agent processing (with a normal user), but not working when started by the Agent.
An error message is presented concerning unexpected Calendar
Error Messages
2015-03-06 12:07:55,602 [ PegaRULES-Batch-5] [ STANDARD] [ ] [ ] (sinessCalendar.CalendarUtility) FATAL - com.pega.pegarules.pub.PRRuntimeException: Multiple timezones not supported for one calendar
Steps to Reproduce
No replication has been tried.
Root Cause
Data-Admin-Calendar instances could be added on many places. It could be added on the OperatorID, AccessGroup and of course WorkObject. But agent will not be having Calendar associated to and this where the confusion was coming from.
Resolution
After having explained and identified which Calendar the system will be using at runtime, it has been decided to add the Calendar name at the WorkObject level using pyCalendar property.
Published January 31, 2016 - Updated October 8, 2020
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