Support Article
Unable to filter report results on an external website
SA-73477
Summary
A complex Search criteria is configured in the User portal and an external website which uses the Pega Web Mashup.
When performing a search on the external website, unable to apply filter on the records that display. The filter screen continues to load indefinitely when filtering. However, this works in the User portal in Pega.
Error Messages
Not Applicable
Steps to Reproduce
- Build a Search logic which can be accessed from the User portal and from Pega Web Mashup. The Search logic must use a report definition which has several joins.
- Search from the external website.
- Apply filtering on any column selection. The filter screen continues to load indefinitely.
Root Cause
The issue occurs due to the the configuration of the parameters how the parameters are passed to the report definition. The parameters are passed through a temporary page which is in different thread (not in the same thread). Hence, the parameters are not found. When the network call occurs, the filtering fails with the 404 error.
Resolution
As a local-change, pass the parameters directly to the report definition instead of passing them through temporary pages.
Published April 12, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.