Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to login after importing an existing Application



We have set up a new cloud environment and then imported an application that was developed (and working) in another environment(non-cloud).In the new environment we are unable to login with the operator that is able to login in old environment. We get "500 Internal server error".

To debug further we tried to create a new ruleset, application rule, Access Group and operator id using the new Access group. We get same error on login with this new application that was created in this environment(not imported). Now, we used Application Express to create a new application and with the new operator created, we are able to login.We checked server logs, application logs but do not see any clue.

Error Messages

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Steps to Reproduce

1. Install Pega 7.1.6 in cloud environment.
2. Import an application (and operators) that was built in non-cloud environment.
3. Try to login into cloud environment with imported operator(or new operator created pointing to imported Application).
4. Get error - "500 Internal Server error"

Root Cause

The root cause of this issue was with the hash value of Access Group. Hash value for ACE:Developers Access Group in URL had %5B%5B in it which was getting blocked (due to SiteMinder) and the HTTP Request from reaching PRPC.


Suggested user to change the name of the access group to ACE:AmexDevelopers which generated hash value which didn't contain %5B%5B in the URL. This resolved the issue
. Also, suggested user to work with SiteMinder team to allow %5B and %5D characters in the HTTP request.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us