Support Article
Unable to open Declare OnChange rule
SA-609
Summary
When developers try to open *any* Declare-OnChange rule in the development environment specifically when using the "Fusion CTI" application, only a blank screen is shown in the main frame. This problem doesn't occur when logged in to other applications in the same environment. Using HTTP Watch, the HTML payload of the Rule-Declare-OnChange.htm rule coming down is seen from the server when reproducing this problem is zero (hence the blank display). The Rule-File-Binary record for the Rule-Declare-OnChange rule form can be previewed correctly by a user with the application that shows the problem, and there are no rule overrides to content included in the rule form. There are no error messages in the PegaRULES logfile, and Tracer shows no failures or problems.
Error Messages
Not Applicable
Steps to Reproduce
Attempt to open a Declare-OnChange rule when logged in with a user with the application "Fusion CTI". A blank screen will be displayed instead of the rule form.
Root Cause
The root cause of this problem is corrupt static content for the Declare-OnChange rule form. It is unclear how/why the static content got corrupted in the first place, however the content was zero bytes on disk.
Resolution
Clearing the E-tier static content cache from the System Management Application (SMA) resolved this issue.
Published March 21, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.