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Support Article

Unable to perform Bulk Processing due to Commit issue

SA-49424

Summary



While using the Bulk processing feature, the screen freezes after clicking process assignments. Additionally, thread dumps with reference to concurrent locks are generated in the logs. This occurs post upgrade to Pega 7.3.1.


Error Messages



Not Applicable


Steps to Reproduce

  1. Upgrade from PRPC 6.3 to Pega 7.3.1.
  2. Execute Bulk processing.
  3. Select cases for bulk processing. Select an action and click Submit.


Root Cause



The primary key was disabled in one of the custom tables. The Commit step took more than 20 minutes due to which the requestor was holding up the database Commit. Hence, bulk processing did not occur.


Resolution



Perform the following local-change:

Enable the primary key.



Published May 23, 2018 - Updated October 8, 2020

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