Support Article
Unable to perform search on the Knowledge Management portal
SA-84315
Summary
Unable to perform a search on the Knowledge Management (KM) portal as no results display on entering a keyword.
Error Messages
Not Applicable
Steps to Reproduce
- Launch the Knowledge Management portal
- Click Knowledge, Help sites and Via Benefits
- Click Preview.
- Perform a search. No results display
Root Cause
In the KMSearchRDHelpSite activity, pyReportClassName points to the out-of-the-box class. The ContentSearchHelpSite report definition is not changed to point to the custom layer.
Resolution
Perform the following local-change:
- Modify the KMSearchRDHelpSite activity
- Modify the ContentSearchHelpSite report definition to use the client's class
- Add the Boost search configuration
- Install HFix-55028
Published December 2, 2021
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