Support Article
Unable to rollack HFix-51555
Summary
Error on performing rollback when HFix-51555 is partially installed.
Error Messages
The Flow Action post-processing activity pzCallRollBackAllHotfixes failed: Failed to find a 'RULE-OBJ-ACTIVITY' with the name 'PZROLLBACKALLHOTFIXES' that applies to 'Data-UpdateManager-ScannerResult'. There were 1 rules with this name in the rulebase, but none matched this request. The 1 rules named 'PZROLLBACKALLHOTFIXES' defined in the rulebase are:
1 unrelated to applies-to class 'Data-UpdateManager-ScannerResult', for example: 'Embed-UpdateManager-InstalledProducts'.
** Failed to find a 'RULE-OBJ-ACTIVITY' with the name 'PZROLLBACKALLHOTFIXES' that applies to 'Data-UpdateManager-ScannerResult'. There were 1 rules with this name in the rulebase, but none matched this request. The 1 rules named 'PZROLLBACKALLHOTFIXES' defined in the rulebase are:
1 unrelated to applies-to class 'Data-UpdateManager-ScannerResult', for example: 'Embed-UpdateManager-InstalledProducts'.
Are you sure you want to roll back all hotfixes? This will remove the hotfixes from the system.
Note: Any changes made to the database schema will NOT be rolled back.
Steps to Reproduce
- Install HFix-51555
- Click Rollback All for the installed hotfix
Root Cause
The issue is due to the packaging of the hotfix. As some of the data instances in the hotfix (For example, DATA-ADMIN-ORGANIZATION PEGA.COM) are shipped in the core platform, a synchronization issue occurs in the Hotfix Manager.
Resolution
Here’s the explanation for the reported behavior:
The system scan looks at all rules and code instances on the system and compares them to the archived instances in the hotfix. For each instance:
- The system scan marks the hotfix as Installed if the system has an identical instance
- The system scan marks the hotfix as Not Installed if the system does not have the instance
- The system scan marks the hotfix as Not Installed if the system has an older instance
- The system scan marks the hotfix as Superseded if the system has a newer instance
A hotfix is made up of the below instances:
- The system marks the hotfix as Installed if the hotfix only contains Installed or Superseded instances
- The system marks the hotfix as Not Installed if the hotfix only contains Not Installed instances
- The system marks the hotfix as Partially Installed if the hotfix contains both Installed or Superseded and Not Installed instances
An Installed or Partially Installed hotfix can be considered either Committed or Uncommitted:
If a hotfix has an entry in the rollback table, it is Uncommitted, else, it is Committed.
When the user installs a hotfix, a Rollback entry is added which the Hotfix Manager uses to select which hotfixes must be rolled back. The rollback entries are cleared while committing a hotfix.
The below image has an example of hotfix synchronization where the hotfix contains both Installed and Not Installed instances:
The system scan works against the hotfix catalog, which contains hotfix information. If a hotfix contains instances that are not unique to the hotfix (For example, if the instances are present in other hotfixes or the shipped system), the instances display as Installed according to the scan. This is illustrated in the above screenshot. Some of the data instances in the hotfix (For example, DATA-ADMIN-ORGANIZATION PEGA.COM) are shipped in the core platform. Hence, this hotfix is always atleast Partially Installed, even before it is installed and after it is rolled back. The status of the hotfix displays as Committed rather than Uncommitted. This occurs since the rollback information is not present.
Published April 4, 2020 - Updated October 8, 2020
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