Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to save a rule in an opened ruleset version

SA-17740

Summary



 Unable to save a rule in to a localized RuleSet as the localized RuleSet are not listed when performing a Save As operation.

Error Messages

Not applicable.


Steps to Reproduce

  1. Open a rule which RuleSet is ABC_fr
  2. Select menu "Save As" of this rule
  3. Unable to save the rule under the ABC_fr opened RuleSet version.


Root Cause



The RuleSet was not listed in an Application Rule. This is the way this feature was intended to function. The observed behaviour is working as designed and the recommendation is to create locale-specific application/rulesets/access groups as described below. 

Resolution

The approach to localizing an application is usually to manually create a new access group and application to facilitate the development of each localization layer. For example, to Localize MyApp to Spanish we would create a MyAppES App with the MyApp_es RuleSets added above the base MyApp RuleSet it corresponded to. This approach would allow Designer Studio to correctly place those RuleSets at design time and affect things like the new/save-as dialogs.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us