Support Article
Unable to save a workitem after upgrade
Summary
Post upgrade to Pega Platform 8.2.1, unable to save a Claim work item.
Error Messages
TempWorkPage.ClaimData.NoticeData.InsuredEconomicLoss(1).EconomicLossDetails.LocationAddress.FeaturePage WrongMode
TempWorkPage.ClaimData.NoticeData.InsuredEconomicLoss(1).EconomicLossDetails.LocationAddress.FeaturePage String adoptDictionaryDefinition(ImmutablePropertyInfo, boolean, boolean) Page the mode has been reset to match the property's definition.
TempWorkPage.OldNoticeData.InsuredEconomicLoss(1).EconomicLossDetails.LocationAddress.FeaturePage WrongMode
TempWorkPage.OldNoticeData.InsuredEconomicLoss(1).EconomicLossDetails.LocationAddress.FeaturePage String adoptDictionaryDefinition(ImmutablePropertyInfo, boolean, boolean) Page the mode has been reset to match the property's definition.
Steps to Reproduce
- Upgrade Pega Platform 7.1.6 to Pega Platform 8.2.1.
- Launch the Pega application.
- Configure a duplicate property in the Inheritance path.
- Initialize the duplicate property to create a work item.
- Save the work item.
Root Cause
An issue in the custom application code or rules.
The duplicate property was in the same Inheritance path but with a different property mode.
Resolution
Perform the following local-change:
- Withdraw the duplicate property.
- Create a new property with a different name.
Published March 19, 2020 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.