Support Article
Unable to start instance on importing custom product rule
SA-63102
Summary
Unable to start the Pega instance after importing a custom application product rule.
Error Messages
Caused by: com.pega.pegarules.pub.context.InvalidApplicationReferenceException: No such Rule-Application instance: SmartDisputeIssuerAll:07.22
Steps to Reproduce
Install a product Rule-Admin-Product (RAP) file in a new environment.
Root Cause
A defect or configuration issue in the operating environment. In the source environment, new versions of Smart Dispute RAPs were installed which were not installed in the target environment.
Resolution
Perform the following local-change:- Install the Smart Dispute RAP files which have the version 07.22
- Import the application RAP file
Published August 24, 2018 - Updated October 8, 2020
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