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Support Article

Unable to start Pega after upgrade from 7.1.6 to 7.1.9

SA-16816

Summary



PegaRules engine start fails to initialize with an error after upgrading from Pega 7.1.6 to Pega 7.1.9 using Install and Update Assistant (IUA) on split schema.

Error Messages



com.pega.pegarules.pub.runtime.IndeterminateConditionalException: Executable.evaluateWhen-Exception Encountered a :java.lang.NullPointerException
at com.pega.pegarules.session.internal.mgmt.Executable.evaluateWhen(Executable.java:4101)

Steps to Reproduce

  1. Upgrade from Pega 7.1.6 to Pega 7.1.9 in split schema mode.
  2. Start an instance.


Root Cause



A defect in Pegasystems’ code or rules.
If the Batch Requestor Type has custom Access Group containing certain Roles like, PegaRULES:SysAdm4, PegaRULES:AutoTest, and so on, it can lead to this issue after an upgrade during first engine initialization.

Resolution



Perform the following local-change:
 
  1. Modify the Batch Requestor Type on the pre-upgraded environment, and give it a default Access Group PRPC:Agents.
  2. Run the upgrade again, or move the database table record corresponding to the Batch Requestor Type from pr_data_admin from the source to the upgraded system after changing the access group to PRPC:Agents.

Published March 11, 2016 - Updated October 8, 2020

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