Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to start Pega application on multiple JVMs on same node

SA-47214

Summary



Unable to start the Pega application on multiple JVMs on the same node.


Error Messages

[XX.xxxxxxxxxxx.com] (cluster.internal.PRClusterImpl) ERROR - Clustering has been disabled on this node by setting 'identification/cluster/protocol' to 'none', however the protocol currently being used by the cluster is 'hazelcast'. This inconsistency will cause functionality that uses the cluster to fail on this node which can lead to data consistency problems and potential data loss. This node should be shutdown and restarted with clustering enabled.


Steps to Reproduce



Configure the Pega application on two different JVMs on the same node.


Root Cause



All the nodes were directed to save the log files to one location which resulted in the system not starting.


Resolution

Perform the below local-change:
  1. Change the location of the temporary directory for all the nodes to a diffrent location
  2. Include the following parameter in the JVM arguments
-Dpega.tmpdir=C:\PegaTemp\pr_temp




Suggest Edit

Published February 2, 2018 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us