Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Unable to transfer work with multiple assignments

SA-97101

Summary



The Bulk Actions functionality is customized to transfer a case which contains multiple open assignments across different operators in Pega 7.1.8. Post upgrade to Pega Platform 8.3, the case is transferred to the operator at the back end correctly. However, the UI displays a Failure status and an error message displays.


Error Messages



Unable to transfer work with multiple assignments.


Steps to Reproduce

  1. Create a case.
  2. Add a sub process in the flow by enabling the 'Spinoff flow' checkbox (or any other approach) to create multiple assignments in the work object.
  3. Execute the case to create the work object with multiple assignments.
  4. Customize the Bulk Actions functionality to transfer the case along with all the assignments to the specific operator.


Root Cause



An issue in the custom application code or rules.
The 'Work-.pzBulkProcessItem' activity is used. This adds the error message to the page at Step 9 after verifying the existence of multiple assignments in a case.



Resolution



Perform the following local-change:

Use the Assign-.pzBulkProcessItem activity. This activity is used by the out-of-the-box Bulk Actions Transfer functionality.

Published July 16, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us