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Support Article

Unable to unlock the Work Object

SA-8465

Summary



When users try to open a work object, they get a message which states that, "the case is locked by you in another session" and an option (button) to end the other session and release the lock, is displayed. When users click this button, they get an error, "Unable to unlock the work object".

Error Messages



Unable to unlock this work object

Steps to Reproduce



The following steps reproduced the issue:
1. Login to Pega application in two sessions with the same user ID.
2. Open a case in Session1 in Perform mode.
3. Open the same case in Session2. It states that the work object is locked by you in other session and the screen has a button to end the other session to release the lock. Click the button.
4. An error message - "Unable to unlock this work object" is displayed.


Root Cause



This issue occurs when the two sessions are from different nodes. If the user logs back in on the same node, the case gets locked after clicking the button.

Resolution



The explanation for this behavior is as follows:
 

The best way to close work is with the buttons available on the work screen.  If the browser is closed, the work is not unlocked right away. 
If a user logs in on a different node but under the same user name and attempts to open the work while it is still locked, a button is displayed - “End other session to Release Lock”. 
When user presses this button, a message is sent to the original node asking for the session to be terminated.  It may take up to 60 seconds for the system pulse to run on that node, after which it ends the session and the session lock is released. 
However, right after you click the “End other session to Release Lock” button, you will see an error saying - “Unable to unlock this work object” because the pulse on the other node has not run

yet.

 

The Support Article - Unable to unlock the workobject (SA-5783) also provides this explanation.

 

Published January 31, 2016 - Updated October 8, 2020

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