Support Article
Unable to update Exchange Appointments
SA-43251
Summary
Error occurs for the UpdateItem Response, post Pega Sales Automation (SA) 7.22 upgrade.
Error Messages
(internal.mgmt.Executable) ERROR localhost|127.0.0.1|Rule-Connect-SOAP.PegaFW-Int-EWS-ExchangeService-.GetUserAvailability EU58207 - Exception
com.pega.pegarules.pub.services.RemoteApplicationException: SOAP service failed
Steps to Reproduce
1. Upgrade Pega SA 7.21 to SA 7.22
2. Update the EWS configurations
3. Run the UpdatePluginSyncedAppointments activity
4. Edit an existing appointment
5. Check the Outlook calendar
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Perform the following local-change:
1. Modify the GetItemResponseForUID Data Transform to set the ChangeKey parameter to:
.GetItemResult.ResponseMessages.GetItemResponseMessage(1).Items.CalendarItem(1).ItemId.ChangeKey
2. Run the update activity for the appointment
Published September 21, 2017 - Updated December 2, 2021
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