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Support Article

Update Wizard throws deadlock errors Reason code "68"

SA-5613

Summary



The application was upgraded to Pega 7.1.7 on WebSphere with DB2 UDB back end database. Running the update wizard tool resulted in deadlock errors.

Error Messages



com.ibm.db2.jcc.am.SqlTransactionRollbackException: The current transaction has been rolled back because of a deadlock or timeout. Reason code "68".. SQLCODE=-911, SQLSTATE=40001, DRIVER=3.64.133
at com.ibm.db2.jcc.am.bd.a(bd.java:666)
at com.ibm.db2.jcc.am.bd.a(bd.java:60)
at com.ibm.db2.jcc.am.bd.a(bd.java:127)


Steps to Reproduce

  1. Attempt to run the post update wizard from the UI in DB2 or Websphere system. 
  2. Navigate to Designer Studio > System > Upgrade > Update Existing Applications.

Root Cause



An error or omission in product documentation:
The connection property webSphereDefaultIsolationLevel must be set in the datasource, which is missing from the Pega 7.1.7 DB2 WebSphere Installation Guide.


Resolution



Perform the following local-change:

Set the connection property webSphereDefaultIsolationLevel=2

Published November 9, 2016 - Updated October 8, 2020

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