Support Article
Updated rule not retrieved post Pega product file deployment
SA-55699
Summary
The updated rule is not retrieved post Pega product file deployment. However, this is resolved only by a clear cache restart.
Error Messages
Not Applicable
Steps to Reproduce
Unknown
Root Cause
A defect or configuration issue in the operating environment.
After an import, the system pulse is responsible to retrieve the new rules. Update the caches accordingly and perform a sync across all nodes.
Resolution
Perform the following local-change such that a restart is not required during an import.
Add the following setting in the prconfig.xml or through the Dynamic System Setting (DSS) in Designer Studio. Adding this setting requires a restart.
<env name="systempulse/scanoffsetms" value="30000" />
This ensures that all the rules are processed during the import.
In case the rules are not retrieved due to issues with the cache, perform the following instead of a restart,
- Navigate to System Management Application (SMA) and select an affected Node. Click Advanced.
- Click the Virtual Rule Table Cache Management. Enter the rule class and instance name (which are not retrieved).
- Click Lookup Virtual Cache table detail. Click Reassemble Candidates. This rebuilds the cache and the rule is now available.
Published July 23, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.