Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Use TLS 1.1 or higher when connecting to Salesforce using HTTPS

SA-25769

Summary



An error occurred when trying to connect Salesforce services. Connect rule was updated to TLS 1.1 for a quick test, but the exception still occurs.

Error Messages



Soap failed.
UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using HTTPS

Steps to Reproduce



Unknown

Root Cause



A defect in Pegasystems’ code or rules:
JDK addresses the issues in the previous code when trust store is not provided in PRPC. JDK 7 uses TLS 1.0 by default.

Resolution



Apply HFix-28509.

See also SA-25578.
Suggest Edit

Published July 27, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us