Support Article
User routed to previous operator ID repeatedly during login
SA-62575
Summary
When logging in to the application, user is routed to the previous operator ID repeatedly.
Error Messages
Not Applicable
Steps to Reproduce
- Log in with an operator ID in the Chrome browser.
- Log off from the browser.
- Log in to the application with another ID. The application opens with previous operator ID.
Root Cause
An issue in the custom application code or rules.
User was logging in from a third-party application which redirected the user to the Pega application. When the user performed the LogOff action, Pega related cookies and sessions were killed but not the third-party application.
Resolution
Here’s the explanation for the reported behavior:
Pega cannot clear the cookies of the third-party application for security reasons. Cookies related to the user are deleted from Pega. However, since the user is logging in to the application from a third-party application, the credentials are saved in the browser cache. Pega is not authorized to delete third-party application details that are stored in the browser.
For more information refer to: https://community.pega.com/support/support-articles/log-not-ending-session-chrome-after-upgrade
As a local-change, perform an OnClick of LogOff to redirect the user to the third-party application and execute operations to end the current user session.
Published January 31, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.