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Support Article

Username is not being logged when accessing from PRCustom SSO

SA-26173

Summary



Pega provides Security Policies landing page where one can set the Audit Log Level to "Advanced" to get Log in log in PR_LOG_SECURITYAUDIT table.
It works totally fine when User was using the regular log in (PRBasic). However in their project they use PRCustom servlet for SSO.

User is involved with SSO, but in this case not able to get the log properly. It tries to log it, such as datetime but the username is blank.


Error Messages



No error message but pyUserIdentifier in the table is blank.


Steps to Reproduce



1. Build SSO.
2. Turn on Audit Log Level in Security Policies from Basic to Advanced.
3. Log in using SSO and check the PR_LOG_SECURITYAUDIT table.


Root Cause



While auditing log, Core Engine did not refer custom SSO Operator ID.

Resolution



Apply HFix-28030 for operator Id on to audit log.
Other information will be refer x-forward HTTP header values, is used on custom SSO servlet. Such as x-forward-remote address.

 

Published August 4, 2016 - Updated October 8, 2020

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