Support Article

Validation failed for Account page after upgrade to PCS 7.14

SA-24818

Summary



After upgrading from CPM 05.02.04 (installed on PRPC 5.4) to Pega Customer Service(PCS) 7.14 installed on Pega 7.1.9, when attempting to clone an existing work object  that is created prior to the upgrade, it fails with the error below. The issue affects work objects created prior to the upgrade that have an embedded page of type Account.

The issue is caused by Page-Change-Class is called on the work page and which is due to the Account property's class type being changed in the upgraded version.


Error Messages



Validation failed: Errors Detected.
.Account: The class of the embedded page should be PegaCA-Interface-Account, but was specified as PegaApp-Interface-Account


Steps to Reproduce



Call Page-Change-Class on the work page to clone the existing work object or change it to a more specific work type.

Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Apply HFix-28093.
Restart the affected nodes and recompile the RULESHORTCUTASSEMBLY library for the changes to take effect.

Published June 22, 2016 - Updated July 21, 2016

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.