Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Visual Business Director fails to load data

SA-18951

Summary



Visual Business Director (VBD) fails with ArrayIndexOutOfBoundsException while loading a very small volume of data using the data source.

Error Messages



Following error is occurring when the Java Applet loads.

Caused By:
----------
>>> Type: java.lang.ArrayIndexOutOfBoundsException
>>> Message: 6
>>> Stack trace:
>>> at com.pega.decision.vbd.service.engine.util.ColumnFamilyGrouping$2.groupValue(ColumnFamilyGrouping.java:123)



Steps to Reproduce



1) Import data into VBD.
2) Launch the VBD Planner by clicking on the data source.

Root Cause



The Data Source was corrupted causing the reported behavior. Creating a new Data Source and writing the same data to it results in it being able to be used. There is one data source provided out-of-the-box that use the Interaction History tables as its source i.e. the ‘Actuals’ Data Source which is retrieved from Interaction History.

Resolution



Additional Data Sets can be created that DO NOT use Interaction History as a Source of their data. In both Pega 7.1.9 (GridGain) and Pega 7.2 (Cassandra) a VBD DataSet other than “Actuals” results in the data being stored in the attached file system.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice