Support Article
When inbox is set up for Auto Reply, it goes into infinite loop
SA-11997
Summary
When inbox is set up for Auto Reply, it goes into infinite loop
email listener listens to emails and replies for those emails. If the User's inbox is set up for Auto Reply, it goes into infinite loop. DSN don't work.
Error Messages
Not Applicable; no error message
Steps to Reproduce
- Configure Email Listener that will respond back on receiving an email.
- Configure Out of the Office/Auto reply for a email account; Email from this account to Email listener inbox.
- Email listener responds back which inturn triggers another email to email listener; hence infinite loop.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. Expected behavior is that Email Listener would not respond to the auto reply/thank you emails.
Resolution
This issue is resolved by hotfix item HFIX-22658
New Dynamic System Setting "Email/AutoReplySubject" is introduced in Pega-IntegrationEngine ruleset which should contain comma separated auto reply subject string that it should avoid responding back to.
Published July 9, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.