Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Getting ADMException: Cannot connect to jdbc/admDataSource

SA-8503

Summary



User reported an error while connecting to Adaptive Decision Manager (ADM).

Error Messages



 [3/30/15 17:07:24:443 IST] 0000000e SystemErr     R com.pega.decision.adm.client.ADMException: Cannot connect to jdbc/admDataSource
 [3/30/15 17:07:24:443 IST] 0000000e SystemErr     R  at com.pega.decision.adm.client.ADMException.raise(ADMException.java:39)
 [3/30/15 17:07:24:443 IST] 0000000e SystemErr     R  at com.pega.decision.adm.dbutils.DBInformation.getDialectProperties(DBInformation.java:50)
 [3/30/15 17:07:24:443 IST] 0000000e SystemErr     R  at com.pega.decision.adm.persist.AbstractDO.getDialectProperties(AbstractDO.java:146)


Steps to Reproduce



Configure Services from Decisioning Services landing page.
 

Root Cause



The behaviour was noticed due to incorrect data source configurations for ADM.

Resolution



User changed the ADM datasource configurations appropriately and was able to connect to ADM. User was able to ping the ADM Service from Decisioning Services landing page.

Published June 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us