Support Article
Refresh of work object on pressing F5 displays error message
SA-9738
Summary
Refreshing an open work object using F5 does not work fine. Operation completes successfully, but returns no content.
Error Messages
Not Applicable
Steps to Reproduce
1. Log in to PRPC
2. Click Organizations
3. Open any Organization
4. Navigate to Trends tab > Customer Interactions tab
6. Click Detailed List
7. Press F5. Operation completes successfully, but returns no content.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. Refresh of portal displays ActivityStatusSuccess Message instead of Work Item.
Resolution
Apply HFix-22121.
When a chart is removed from client a request is send to Server (pzRuntimeChartCleanup Activity to remove Data Page bounded to it).
Instead of calling it directly through asyncRequest, PRPC OOTB runActivity API is used.
pega.u.invoke.runActivity(["pzRuntimeChartCleanup","chartID="+this.element.attr('id'),"",null,"",""]);
Published November 9, 2015 - Updated October 8, 2020
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