Support Article
Unable to start email listener, getting MBEAN access error
SA-14387
Summary
When trying to start one particular Email Listener, an error is thrown. This listener had been working fine for some time. Nothing has changed in the environment or on the email server side.
Error Messages
2015-09-09 09:25:55,340 [nectorThreadPool : 1] [ STANDARD] [ ] (vices.listener.ListenerWrapper) ERROR - Failed to start listener: EMAIL.YourListener.Listener, com.pega.pegarules.pub.PRException: Authentication failed for listener: EMAIL.YourListener.Listener
From: (AF3F05831E67A032DA8FFCDEAFCA58F9D)
2015-09-09 09:25:55,340 [nectorThreadPool : 1] [ STANDARD] [ ] (tener.ListenerStateManagerImpl) ERROR - Unexpected exception.
com.pega.pegarules.pub.PRException: Failed to start listener: EMAIL.YourListener.Listener
From: (B861AF5ECCBCBB6ED8405013C210A4F63:(MBean Access))
...
Caused by:
com.pega.pegarules.pub.services.ServiceException: Authentication failed
at com.pega.pegarules.integration.engine.internal.services.ServiceAPI.handleAuthentication(ServiceAPI.java:1281)
at com.pega.pegarules.integration.engine.internal.services.ServiceAPI.setRequestorPrivileges(ServiceAPI.java:2689)
Steps to Reproduce
Not applicable.
Root Cause
An issue in the custom application code or rules. The authentication that is failing is not for the email server, but for the Operator listed under the Requestor Login section of the Email Listener rule form.
Resolution
Perform the following local-change: Update the requestor userID and password on the Email Listener rule form and ensure that they are correct.
Published October 1, 2015 - Updated October 8, 2020
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