Support Article
LIMIT BEING EXCEEDED pr_hourly_usage table
SA-19006
Summary
LIMIT BEING EXCEEDED error associated with pr_hourly_usage table in Pega 7.1.9.
Error Messages
SQLCODE = -905, ERROR: UNSUCCESSFUL EXECUTION DUE TO RESOURCE
LIMIT BEING EXCEEDED
Steps to Reproduce
Not Applicable.
Root Cause
A defect or configuration issue in the operating environment. There were 1.5 million records in the pr_hourly_usage table, it is because with that many rows in the table it appears that the SPPR_AGGREGATE_USAGE stored procedure for licensing is not running on a nightly basis as it should. When license daemon executes and invokes SPPR_AGGREGATE_USAGE stored procedure, it processes records in PR_HOURLY_USAGE which are reflected in the Usage summary report. As PR_HOURLY_USAGE table had 1.5 million records therefore transaction limit was exceeding
Running following SQL query: select * from pr_license_parameters where pyName = 'pyRetainHourly'
PYNAME PYUSERTYPE PYVALUE
-------------------------------- -------------------------------- --------------------------------
pyRetainHourly SYSTEM 200
The value for pyRetainHourly, which sets the threshold when the data must be purged from pr_hourly_usage table was 200 days, that is why there there were over 1.5 million record in PR_HOURLY_USAGE table. pyRetainHourly value OOB should be 8 days.
Resolution
Make the following change to the operating environment:
Truncate PR_HOURLY_USAGE table and redeploy Data-Admin-License record to adjust the “hourly” data retention period to 8 days.
Licence daemon will now keep the size of pr_hourly_usage table within limit.
Published January 31, 2016 - Updated December 2, 2021
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