Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Error occurs when sending an email

SA-91200

Summary



Error occurs when sending an email.


Error Messages



1. Test connectivity is successful with below host and port and 'Email/DisableSecuritySTARTTLS' DSS is set to true.

Host: smtp.gmail.com
Port: 587 and 25
Exception: 530 5.7.0 Must issue a STARTTLS command first

2. Test connectivity throws below exception when the port is 465 and 'Email/DisableSecuritySTARTTLS' DSS set to false.

Host: smtp.gmail.com
Port: 465
Response: -1
Exception: javax.mail.MessagingException: Could not connect to SMTP



Steps to Reproduce



Configure an email account for the Gmail provider with an SMTP host.


Root Cause



Only SSL port works for SMTP host (smtp.gmail.com). The Gmail provider has restricted this.


Resolution



1. A different Gmail host is available to send emails which works without SSL.

Host: aspmx.l.google.com
Ports supported: 25 and 587

2. The errors are the same when the user connects the Gmail SMTP host (smtp.gmail.com) from a standalone Java code and when the user connects from Pega to Gmail SMTP host expecting SSL connectivity while sending the email.

Perform the steps to work with SMTP host. Use the Gmail SSL port 465 to connect using SSL. 
  • Specify the Keystore and Certificate Alias for Gmail.
  • Check the SMTPS option. Test the Connectivity.

Published October 31, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice